简易论坛

 找回密码
 免费注册

QQ登录

只需一步,快速开始

新人指南 免费原创下载 - 注册/登陆教程 - 获取各项积分 邀请注册(奖) - 发帖/回帖教程 - 违规/禁言标准

个人中心 拍卖行 - 空间首页- 个人收藏 - 悬赏问答 道具商店- 任务中心- 勋章领取- 我的好友

论坛版规 广告招租 - 赞助我们 - 网站公告 - App版下载 解除禁言 - 申请认证 - 积分说明 - 有奖举报

3网H5易支付对接格子广告低价招租81元永久会员代刷格子广告低价招租81易支付 费率0.2%
查看: 1251|回复: 0

[板块] 琢啄皮肤皮肤模块(内存版)

[复制链接]

60

主题

244

帖子

152

积分

小学三年级

Rank: 5Rank: 5Rank: 5

UID
1481
金币
0
易币
12
任务点
0
下载点
525
发表于 2013-8-15 12:09:04 | 显示全部楼层 |阅读模式

温馨提醒:该信息发布时间距现在超过30天了,可能内容已过期,链接或者软件已失效,请酌情使用

使用QQ登陆,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?免费注册

x
本帖最后由 Faith_汐夏° 于 2013-8-15 12:10 编辑











模块名称:啄啄皮肤模块(内存版)v5.0
作者:啄啄
版本:5.0

啄啄皮肤模块(内存版)v5.0
本版为最终版,模块功能大家自己添加吧
@备注:
本版本为 啄啄皮肤模块的最终版

------------------------------

.版本 2

.子程序 皮肤_Aero设置, 整数型, 公开, 在内存中设置
.参数 透明度, 整数型, 可空
.参数 亮度, 整数型, 可空
.参数 锐度, 整数型, 可空
.参数 阴影大小, 整数型, 可空
.参数 水平偏移, 整数型, 可空
.参数 垂直偏移, 整数型, 可空
.参数 红色分量, 整数型, 可空
.参数 绿色分量, 整数型, 可空
.参数 蓝色分量, 整数型, 可空

.子程序 皮肤_Aero特效, 整数型, 公开, 在内存中设置
.参数 开启关闭, 逻辑型, , 真.开启 假.关闭

.子程序 皮肤_保存方案, 逻辑型, 公开, 保存一套方案,便于加载
.参数 皮肤, 字节集
.参数 色调, 整数型, 可空
.参数 饱和度, 整数型, 可空
.参数 亮度, 整数型, 可空
.参数 是否Aero特效, 逻辑型
.参数 透明度, 整数型, 可空
.参数 红色分量, 整数型, 可空
.参数 蓝色分量, 整数型, 可空
.参数 绿色分量, 整数型, 可空
.参数 亮度2, 整数型, 可空
.参数 锐度, 整数型, 可空
.参数 阴影大小, 整数型, 可空
.参数 水平偏移, 整数型, 可空
.参数 垂直偏移, 整数型, 可空
.参数 方案名, 文本型, , 保存方案的位置,可以为任何后啜名

.子程序 皮肤_背景颜色, 整数型, 公开, 在内存中设置(目前仅对单选框,复选框,分组框有效)
.参数 控件句柄, 整数型
.参数 红色分量, 整数型
.参数 绿色分量, 整数型
.参数 蓝色分量, 整数型

.子程序 皮肤_标题菜单, 整数型, 公开, 在内存中设置
.参数 窗口句柄, 整数型
.参数 开启关闭, 逻辑型, , 真.开启 假.关闭
.参数 菜单栏高度, 整数型
.参数 上部偏移, 整数型
.参数 右部偏移, 整数型

.子程序 皮肤_查看方案, 逻辑型, 公开, 查看方案配置
.参数 方案名, 文本型, , 欲查看的方案
.参数 皮肤, 字节集, 参考
.参数 色调, 整数型, 参考
.参数 饱和度, 整数型, 参考
.参数 亮度, 整数型, 参考
.参数 是否Aero特效, 逻辑型, 参考
.参数 透明度, 整数型, 参考
.参数 红色分量, 整数型, 参考
.参数 蓝色分量, 整数型, 参考
.参数 绿色分量, 整数型, 参考
.参数 亮度2, 整数型, 参考
.参数 锐度, 整数型, 参考
.参数 阴影大小, 整数型, 参考
.参数 水平偏移, 整数型, 参考
.参数 垂直偏移, 整数型, 参考

.子程序 皮肤_导出方案, 逻辑型, 公开, 导出当前的皮肤状态,以方案形式保存
.参数 方案名, 文本型

.子程序 皮肤_定时更换, 整数型, 公开, 定时更换皮肤
.参数 更换时间, 整数型, , 已秒为单位
.参数 皮肤一, 字节集
.参数 皮肤二, 字节集
.参数 皮肤三, 字节集

.子程序 皮肤_定时停止, 整数型, 公开, 停止定时更换皮肤

.子程序 皮肤_方案资源, 字节集, 公开, 获取方案的字节集,区别是,他不写出文件,而是返回字节集
.参数 皮肤, 字节集
.参数 色调, 整数型, 可空
.参数 饱和度, 整数型, 可空
.参数 亮度, 整数型, 可空
.参数 是否Aero特效, 逻辑型
.参数 透明度, 整数型, 可空
.参数 红色分量, 整数型, 可空
.参数 蓝色分量, 整数型, 可空
.参数 绿色分量, 整数型, 可空
.参数 亮度2, 整数型, 可空
.参数 锐度, 整数型, 可空
.参数 阴影大小, 整数型, 可空
.参数 水平偏移, 整数型, 可空
.参数 垂直偏移, 整数型, 可空

.子程序 皮肤_换肤类型, 整数型, 公开, 在内存中设置(类型详见常量)
.参数 控件句柄, 整数型
.参数 换肤类型, 整数型, , (类型详见常量)

.子程序 皮肤_绘画控件, 整数型, 公开, 在内存中在制定位置绘画制定控件
.参数 窗口句柄, 整数型, , 要绘画在哪个窗口上
.参数 左边, 整数型
.参数 顶边, 整数型
.参数 右边, 整数型
.参数 底边, 整数型
.参数 皮肤控件ID, 整数型

.子程序 皮肤_继续更换, 整数型, 公开, 继续定时更换皮肤

.子程序 皮肤_加载方案, 逻辑型, 公开, 载入保存的方案
.参数 方案名, 文本型

.子程序 皮肤_加载默认, 整数型, 公开, 在内存中加载,加载运行目录下的skinh.she

.子程序 皮肤_加载指定, 整数型, 公开, 在内存中加载指定目录下的she皮肤
.参数 完整路径, 文本型
.参数 皮肤密码, 文本型, 可空

.子程序 皮肤_接口文件, 逻辑型, 公开, 导出破解版接口文件
.参数 目标文件, 文本型

.子程序 皮肤_列表加载, 整数型, 公开, 在内存中设置
.参数 窗口句柄, 整数型
.参数 是否开启, 逻辑型, , 真.开启 假.关闭

.子程序 皮肤_设置透明, 整数型, 公开, 在内存中设置
.参数 窗口句柄, 整数型
.参数 透明度, 整数型

.子程序 皮肤_是否可移, 整数型, 公开, 在内存中设置
.参数 窗口句柄, 整数型
.参数 是否可移动, 逻辑型, , 真.可以 假.不可以

.子程序 皮肤_释放内存, 逻辑型, 公开, 释放内存DLL,最好在窗口结束时和皮肤卸载放着一起用

.子程序 皮肤_随机配置, 整数型, 公开, 随机进行配置
.参数 是否进行Aero设置, 逻辑型, , 真.是 假.不是

.子程序 皮肤_随机皮肤, 整数型, 公开, 随机加载3个皮肤,过多会是exe变大,返回加载的皮肤序号,失败为0
.参数 皮肤一, 字节集, 可空, 参与随机的皮肤
.参数 皮肤二, 字节集, 可空, 参与随机的皮肤
.参数 皮肤三, 字节集, 可空, 参与随机的皮肤

.子程序 皮肤_文本颜色, 整数型, 公开, 在内存中设置(目前仅对单选框,复选框,分组框有效)
.参数 控件句柄, 整数型
.参数 红色分量, 整数型
.参数 绿色分量, 整数型
.参数 蓝色分量, 整数型

.子程序 皮肤_卸载指定, 整数型, 公开, 在内存中卸载指定控件皮肤
.参数 控件句柄, 整数型, , 欲卸载皮肤的控件

.子程序 皮肤_颜色设置, 整数型, 公开, 在内存中设置
.参数 色调, 整数型, 可空
.参数 饱和度, 整数型, 可空
.参数 亮度, 整数型, 可空

.子程序 皮肤_制定加载, 整数型, 公开, 在内存中设置
.参数 完整路径, 文本型
.参数 皮肤密码, 文本型, 可空
.参数 色调, 整数型, , 取值范围-180-180,默认值0
.参数 饱和度, 整数型, , 取值范围-180-180,默认值0
.参数 亮度, 整数型, , 取值范围-180-180,默认值0

.子程序 皮肤_资源方案, 逻辑型, 公开, 载入保存的方案,区别是,以字节集格式载入
.参数 方案资源, 字节集, , 可以是自己的

.子程序 皮肤_资源加载, 整数型, 公开, 在内存中加载
.参数 资源, 字节集
.参数 密码, 文本型, 可空
.参数 色调, 整数型, 可空
.参数 饱和度, 整数型, 可空
.参数 亮度, 整数型, 可空

.子程序 皮肤_资源卸载, 整数型, 公开, 在内存中卸载

.常量 换肤类型_Delphi_窗体, "3001", 公开, 换肤类型:窗体(Delphi)
.常量 换肤类型_Delphi_分组框, "3004", 公开, 换肤类型:分组框(Delphi)
.常量 换肤类型_Delphi_位图按钮, "3002", 公开, 换肤类型:位图按钮(Delphi)
.常量 换肤类型_Delphi_暂时未知, "3003", 公开, 换肤类型:
.常量 换肤类型_IP地址控件, "1011", 公开, 换肤类型:IP地址控件
.常量 换肤类型_MDI客户区, "1015", 公开, 换肤类型:MDI客户区
.常量 换肤类型_MFC工具栏窗体, "1030", 公开, 换肤类型:MFC工具栏窗体
.常量 换肤类型_Net_标签, "2001", 公开, 换肤类型:标签(.Net)
.常量 换肤类型_Net_菜单栏, "2007", 公开, 换肤类型:菜单栏(.Net)
.常量 换肤类型_Net_窗体, "2002", 公开, 换肤类型:窗体(.Net)
.常量 换肤类型_Net_单选框, "2004", 公开, 换肤类型:单选框(.Net)
.常量 换肤类型_Net_复选框, "2003", 公开, 换肤类型:复选框(.Net)
.常量 换肤类型_Net_工具菜单, "2009", 公开, 换肤类型:工具菜单(.Net)
.常量 换肤类型_Net_工具栏, "2006", 公开, 换肤类型:工具栏(.Net)
.常量 换肤类型_Net_工具溢出菜单, "2010", 公开, 换肤类型:工具溢出菜单(.Net)
.常量 换肤类型_Net_普通按钮, "2005", 公开, 换肤类型:普通按钮(.Net)
.常量 换肤类型_Net_数据视图, "2011", 公开, 换肤类型:数据视图(.Net)
.常量 换肤类型_Net_状态栏, "2008", 公开, 换肤类型:状态栏(.Net)
.常量 换肤类型_PB_窗体, "6001", 公开, 换肤类型:窗体(PB)
.常量 换肤类型_PB_图片框, "6002", 公开, 换肤类型:图片框(PB)
.常量 换肤类型_PB_选择夹, "6003", 公开, 换肤类型:选择夹(PB)
.常量 换肤类型_VB6_窗体, "4001", 公开, 换肤类型:窗体(VB6)
.常量 换肤类型_VB6_单选框, "4003", 公开, 换肤类型:单选框(VB6)
.常量 换肤类型_VB6_分组框, "4005", 公开, 换肤类型:分组框(VB6)
.常量 换肤类型_VB6_复选框, "4004", 公开, 换肤类型:复选框(VB6)
.常量 换肤类型_VB6_普通按钮, "4002", 公开, 换肤类型:普通按钮(VB6)
.常量 换肤类型_VB6_数据组合框, "4007", 公开, 换肤类型:数据组合框(VB6)
.常量 换肤类型_VB6_选择夹, "4006", 公开, 换肤类型:选择夹(VB6)
.常量 换肤类型_标签控件, "1012", 公开, 换肤类型:标签控件
.常量 换肤类型_标准窗体, "1034", 公开, 换肤类型:标准窗体
.常量 换肤类型_菜单, "1016", 公开, 换肤类型:菜单
.常量 换肤类型_单选框, "1021", 公开, 换肤类型:单选框
.常量 换肤类型_调节器, "1026", 公开, 换肤类型:调节器
.常量 换肤类型_动画控件, "1001", 公开, 换肤类型:动画控件
.常量 换肤类型_分组框, "1008", 公开, 换肤类型:分组框
.常量 换肤类型_复选框, "1002", 公开, 换肤类型:复选框
.常量 换肤类型_富文本框, "1023", 公开, 换肤类型:富文本框
.常量 换肤类型_工具栏, "1029", 公开, 换肤类型:工具栏
.常量 换肤类型_滚动条, "1024", 公开, 换肤类型:滚动条
.常量 换肤类型_滑条控件, "1031", 公开, 换肤类型:滑条控件
.常量 换肤类型_进度条, "1019", 公开, 换肤类型:进度条
.常量 换肤类型_控件栏, "1005", 公开, 换肤类型:控件栏
.常量 换肤类型_列表框, "1013", 公开, 换肤类型:列表框
.常量 换肤类型_列表视图, "1014", 公开, 换肤类型:列表视图
.常量 换肤类型_列头控件, "1009", 公开, 换肤类型:列头控件
.常量 换肤类型_内置滚动条的控件, "1025", 公开, 换肤类型:内置滚动条的控件
.常量 换肤类型_普通按钮, "1020", 公开, 换肤类型:普通按钮
.常量 换肤类型_热键控件, "1010", 公开, 换肤类型:热键控件
.常量 换肤类型_日期控件, "1006", 公开, 换肤类型:日期控件
.常量 换肤类型_树形视图, "1032", 公开, 换肤类型:树形视图
.常量 换肤类型_通用换肤1, "1036", 公开, 换肤类型:通用换肤1
.常量 换肤类型_通用换肤2, "1037", 公开, 换肤类型:通用换肤2
.常量 换肤类型_图片框, "1018", 公开, 换肤类型:图片框
.常量 换肤类型_未知类型, "0", 公开, 换肤类型:未知类型
.常量 换肤类型_文本框, "1007", 公开, 换肤类型:文本框
.常量 换肤类型_选择夹, "1028", 公开, 换肤类型:选择夹
.常量 换肤类型_易语言_窗体, "5002", 公开, 换肤类型:窗体(易语言)
.常量 换肤类型_易语言_文本框, "5001", 公开, 换肤类型:文本框(易语言)
.常量 换肤类型_易语言_颜色选择器, "5003", 公开, 换肤类型:颜色选择器(易语言)
.常量 换肤类型_月历控件, "1017", 公开, 换肤类型:月历控件
.常量 换肤类型_重组栏, "1022", 公开, 换肤类型:重组栏
.常量 换肤类型_状态栏, "1027", 公开, 换肤类型:状态栏
.常量 换肤类型_组合框, "1003", 公开, 换肤类型:组合框
.常量 换肤类型_组合下拉框, "1004", 公开, 换肤类型:组合下拉框

.图片 pf_adamant, 公开
.图片 pf_AERO, 公开
.图片 pf_Angel, 公开
.图片 pf_AngelBSC, 公开
.图片 pf_Aquanox, 公开
.图片 pf_ASUS, 公开
.图片 pf_BLACK, 公开
.图片 pf_CHINA, 公开
.图片 pf_CRYSTAL, 公开
.图片 pf_DOGMAX, 公开
.图片 pf_ENJOY, 公开
.图片 pf_IAIQOL, 公开
.图片 pf_IllumeCG, 公开
.图片 pf_INSOMNIA, 公开
.图片 pf_ITUNES, 公开
.图片 pf_KingMe, 公开
.图片 pf_MSN, 公开
.图片 pf_OFFICE2007, 公开
.图片 pf_OUFRAME, 公开
.图片 pf_QQ2008, 公开
.图片 pf_QQ2009, 公开
.图片 pf_QQ2009_宽_底边, 公开
.图片 pf_QQ2009_窄_底边, 公开
.图片 pf_QQ2010, 公开
.图片 pf_QQ2011, 公开
.图片 pf_QQGAME, 公开
.图片 pf_QQmuisc, 公开
.图片 pf_QQMusic3, 公开
.图片 pf_QQ管家, 公开
.图片 pf_QQ影音, 公开
.图片 pf_SHWIN, 公开
.图片 pf_VISTA, 公开
.图片 pf_WHITEFIRE, 公开
.图片 pf_Win7, 公开
.图片 pf_win8, 公开, 谢谢 辅助区班主 q105提供
.图片 pf_XENES, 公开
.图片 pf_XMP, 公开
.图片 pf_城中荷塘, 公开
.图片 pf_纯净皮肤, 公开
.图片 pf_蜂窝巢, 公开
.图片 pf_海边住宅, 公开
.图片 pf_呵呵黑色, 公开
.图片 pf_呵呵绿色, 公开
.图片 pf_呵呵紫色, 公开
.图片 pf_黑粉MM, 公开
.图片 pf_黑酷, 公开
.图片 pf_黑色007, 公开
.图片 pf_黑条白板, 公开
.图片 pf_红蓝渐变, 公开
.图片 pf_红墨水, 公开
.图片 pf_空间红, 公开
.图片 pf_麻布, 公开
.图片 pf_漂流瓶, 公开
.图片 pf_七彩条幅, 公开
.图片 pf_清爽蓝色, 公开
.图片 pf_生锈贴片, 公开
.图片 pf_时空穿梭, 公开
.图片 pf_天际蓝, 公开
.图片 pf_夏天, 公开
.图片 pf_小黑, 公开
.图片 pf_悬空浮楼, 公开
.图片 pf_迅雷, 公开
.图片 pf_迅雷7, 公开
.图片 pf_永不言败, 公开, 谢谢 辅助区班主 q105制作
.图片 pf_幽光绿, 公开
.图片 pf_正点蓝色, 公开
.图片 pf_重金属, 公开
.图片 pf_啄啄八号, 公开
.图片 pf_啄啄二号, 公开
.图片 pf_啄啄九号, 公开
.图片 pf_啄啄六号, 公开
.图片 pf_啄啄七号, 公开
.图片 pf_啄啄三号, 公开
.图片 pf_啄啄十号, 公开
.图片 pf_啄啄四号, 公开
.图片 pf_啄啄五号, 公开
.图片 pf_啄啄一号, 公开
.图片 pf_紫定义, 公开


琢啄皮肤皮肤模块(内存版).zip

1.57 MB, 下载次数: 3, 下载积分: 易币 -1 , 下载点 -1

综合技术交流平台 https://bbs4.cn
您需要登录后才可以回帖 登录 | 免费注册

本版积分规则

简易论坛-综合技术免费交流平台发布的琢啄皮肤皮肤模块(内存版)帖子由网友提供或转载于网络,若发布的琢啄皮肤皮肤模块(内存版)侵犯了您的权益,请联系我们.
关闭

站长推荐上一条 /3 下一条

发布主题 上个主题 下个主题 快速回复 收藏帖子 返回列表 搜索
现在加入简易论坛,注册一个账号

QQ|小黑屋|手机版|Archiver|简易论坛 |网站地图
ANK V1.1.6 正式版智能驱动支持|本站受香港法律保护,免国内备案运行!

GMT+8, 2020-7-14 08:15 , Processed in 0.062351 second(s), 16 queries , Gzip On, File On.

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.  创始人:柒铖鸿

快速回复 返回顶部 返回列表